Arizona Fishing Forums on AZBZ banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1,992 Posts
Discussion Starter · #1 ·
Guys my dishwasher stopped working. Can anyone recomed a good repairman in the West Valley?
 

·
Registered
Joined
·
6,622 Posts
yes, called sink, soap and dish towel!!!!!!
 

·
Registered
Joined
·
2,334 Posts
Try Mike at East Valley Appliance Repair. Despite the name, he may do work in the WV. Most honest, accurate, reasonable, appliance guy I have met. I call his people everytime.

480-824-3685
 

·
Registered
Joined
·
3,569 Posts
Try Mike at East Valley Appliance Repair. Despite the name, he may do work in the WV. Most honest, accurate, reasonable, appliance guy I have met. I call his people everytime.

480-824-3685
+1... I have never used them but we do a lot of work for property management companies and that's who they have recomeded
 

·
Registered
Joined
·
1,717 Posts
Mac, just a question. Is your dishwasher plugged into a GFI circuit? You might want to see if the GFI is tripped.

+1...Check every GFI inside and outside the house, since there's no telling how many loops are in the circuit. Most codes do require a GFI within 3' of water, so there's likely to be one in the cabinet next to the DW, or it will be in in series with another one somewhere in the house.
 

·
Registered
Joined
·
1,992 Posts
Discussion Starter · #8 ·
Guys,

It's not the GFI. The lights just blink on and off. From what I have researched it seems to be wither the heating element or the board. I have tried resetting the unit and it still does not work. BTW it is a Whirlpool Gold Quiet Partner III and it is by far the worst dishwasher we have ever used.

Bruce, the kids are getting tired of doing the dished by hand! :Iconrotfl:Iconrotfl:Iconrotfl
 

·
Registered
Joined
·
3,831 Posts
My niece had a brand new dishwasher sitting around that I believe she wants to sell. Let me know if you're interested.
 

·
Registered
Joined
·
38 Posts
Guys,

It's not the GFI. The lights just blink on and off. From what I have researched it seems to be wither the heating element or the board. I have tried resetting the unit and it still does not work. BTW it is a Whirlpool Gold Quiet Partner III and it is by far the worst dishwasher we have ever used.

Bruce, the kids are getting tired of doing the dished by hand! :Iconrotfl:Iconrotfl:Iconrotfl
odds its the board most of the time when its the heater it blows a thermo fuse note to all u gfi guys the d/w & disposel are on a dedicated circuit
 
1 - 10 of 10 Posts
Top