Arizona Fishing Forums on AZBZ banner

1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
Hey Delw, I`m in Need of some help. Just got back from Bartlett and I have oil all over the motor. I think the top tank is leaking or an oil line is, this something you can fix? This week. Thanks Jamie
 
G

·
Discussion Starter · #2 ·
Probally.

will call you tomorrow?

Ben and Phil were hot on pleasant yesterday, what happened to Jeffs Mechanics where they off again? LOL (you can blame it on him he doesnt read the net) :wink:

Delw
 
G

·
Discussion Starter · #3 ·
Jeff needs to learn how to set the hook on fish in 55ft of water. He cost us the derby.(LOL) He`d get them to the top and out the hook would come. It cost us big. Jamie
 
G

·
Discussion Starter · #4 ·
Jamie, I had the same problem with the Yamaha motor. The rubber boot that holds the oil sensor maybe dried out. if you fill the oil resevoir (sp) just below that boot, you'll be OK. You'll have to keep a quart of oil on your boat at all times and check the oil level after EVERY trip. Replacing the boot is no big deal, but can be pricey, due to the electronic sensor that's involved . just a personal experience. If the resevoir (sp) is kept at the level mentioned above and the leaking has stopped. you'll be ok. Make sure that when you start this test, that the base around the block is all cleaned up. if you come back the next morning and there's a puddle around the block or on the garage floor. You have a line problem. If you have oil sprayed all over the cowling (sp) and block, you have a seal, line problem. Delw can fix anything! Good luck!
 
1 - 4 of 4 Posts
Top