Arizona Fishing Forums on AZBZ banner
1 - 4 of 4 Posts

·
Registered
Joined
·
637 Posts
Discussion Starter · #1 ·
Hi Delw,

I have an 82 Ranger with Merc 150 Black Max. The buzzer keeps going off when I'm at high speed after a few minutes. I think the temp sending unit is bad. I was looking at it and the wire was all corroded and broke off. I cannot get the temp sending unit out of the head. Is there a special tool? Help. Also do you have one? I called Complete Marine and theirs was $70. I also would like to get a dash like yours on your Ranger (the aluminum) Let me know if you ever make them or sell that one.

Thanks
John
 

·
Premium Member
Joined
·
34,643 Posts
More than likely the reason you are over heating is because you are not getting enough water to the block at full speed.


1. by a impellor that needs to be replaced( more than likely)

2. over trimmed or the motor sets way to high(your motor was low if remember correctly.)

Could also be
thermostats being clogged shut(doubtfull but does happen)

YOu need to get it fixed IMMed. cause you take it out and over heated it one or tomany times you can kiss the motor good by,

Without a water pressure gauge you dont have anyidea what water pressure you are getting.

The sensor since i does go off that means it works, if they go bad(very very doubtful) they will either stay on all the time or not work at all, Again a pressure gauge would let you know these things.

to take the sensor out take the retaining bolt out of the head. Spray the heck out of it with wd 40 or something close. get a SMALL hammer and punch and LIGHTLY tap the sensor a few times repeat this process a few times during the day and keep it soaked with wd-40.

if this doesnt work then you have to drill the sensor out. best way is to drill a small hole in it then tap it then use a slide hammer to pull it out.
also you can use a dremmel tool and cut it out but makle sure you dont cut the head at all.

They are dealer items only. I could get one but you would have to pay the same price as me.

The dash would have to be custom fitted with the gauges you have. I could do it but the price wouldnt be cheap, you talking somewhere around $200-$400. Also then you would probally want to get new gauges and switchs since yours are old so then your looking at another $400-$600 bucks.


Save your money and get a Waterpressure gauge.

And dont take your boat out again until you get it fixed, otherwise it might be new motor time and they are not cheap.

Delw



 

·
Registered
Joined
·
637 Posts
Discussion Starter · #3 ·
Delw,

I am ordering a water pressure kit. In the mean time I need to replace the temp sensor. The wire was barely hanging on and when I wiggled it it broke off. The sensor is loose in the hole but I cannot pull it out. The head is still on. Do I need to take the head off? Can I add a temperature gage so I don't have an idiot buzzer only?

Thanks
John
 

·
Premium Member
Joined
·
34,643 Posts
You can add a temp gauge but its not near as good and fool proof as the idiot buzzard. When they buzz something is wrong. what happens when you are flying down the lake and dont pay attention to the gauges, (its to late then). the buzzard is so damn obnoxious that you and everyone around you will hear it.

if you can wiggle it then it will come out, Something will get it out, if not drill a hole in it and tap it use a slide hammer and pull it out.


no need to take the head off, there is just a little cylinder moled in the head that hods the sensor. the sensor doesnt touch water just the head walls.


Delw



 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top