AZBZ Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,019 Posts
Discussion Starter #1
Was unloading the other day and started to slip so I pushed the 4-hi button which started blinking, which then should go solid when 4 wheel is engaged after a couple of rotations of the wheels. Well lets say it just kept blinking and I never could get it into 4 hi or 4 low. When I would push the button you could hear like it was disengageing from 2 wheel drive but would not lock into 4 wheel. Delw, or anyone have any ideas before I go spend half a months salary to get this looked at.
I thought that electronic 4-wheel drive was kinda dumb, just more electronics to go bad and more moving parts to go bad why not a shift on the fly or just the simple locking of the hubs.
Any help would be appreciated
thanks
 

·
Registered
Joined
·
8,008 Posts
'99 Silverado here...not sure if this helps but I always throw mine into neutral and shift it. I've never had a problem although I've never attempted while sliding on the ramp. My guess it's more of a procedure problem with how you're doing it than a problem of the mechanical side. Good luck - I know the feeling!
 

·
Registered
Joined
·
1,948 Posts
I think hes right. The vehicle needs to be in Neutral to shift into 4 wheel drive. Most vehicles have the directions for shifting into 4 wheel drive above the drivers side visor. If yours doesnt,let me know and ill email you the directions on this operation,and yes the vehicle needs to be stopped in Neutral first....
 

·
Registered
Joined
·
4,166 Posts
I have a 97 Chev silverado but my shifter is on the floor. to shift into 4 hi I can be moving in drive but for four low I need to put it into neutral.
 
G

·
Guest
Joined
·
0 Posts
I have a 1990 chevy 4x4 , to shift into high 4 x4 you just need to move the shifter.
On my dads old 98 same thing except a button on his new 2003 same thing button.

But to get into low you must stop and shift into netrual and have the engine at idle speed.

On my 90 there are 2 solenoids on the differential. I believe one is for low and one for high. I blew my high solenoid 2 times and once it was just the wireing got ripped out.

So check your fuses first then check to see if the soleniod works.
if the fuse is good make sure your wires are hooked up, if they are good make sure you are getting power to the solenoid. if that works then hold you hand on the solenoid while someone hits the button you should get a good click.
Dont by the parts from anywhere except tthe dealer or napa

Delw
 

·
Registered
Joined
·
5,343 Posts
The solenoid on the front end is out. it costs about 150.00 and you can do it yourself. the only thing you need to be in neutral is for 4 low. 4 high will shift up to 35 mph. i had the same thing happen to my old 93 chevy. the solenoid will be on the front pumpkin on the passengers side and will have 2 wires going to it. it basically pushes a rod in to the gears to engage your 4x4.
 

·
Registered
Joined
·
1,470 Posts
I know what will fix that...
F O R D

LOL! Just kiddin, I hope you get your truck fixed real soon. I have heard that in some cases (depending on the type of 4WD and transfer case) the front wheels need to roll a little bit before they take hold. Knida like put it into 4WD before it's needed. I'd doubt that's the case though in a full size pick up. Anyway, good luck and FISH ON!
 

·
Registered
Joined
·
1,019 Posts
Discussion Starter #11
Thanks all for the reply but I think what Boat cop or Del said is the problem I am having, since I do know how my truck shifts into 4-wheel ( done it a thousand times).
When you push the 4-hi button it takes a few rotations before it is suppose to lock in. I didnt just try on the ramp once I got home I tried everything to get it to lock in with no luck. I will replace that solenoid.
Again thanks for the replys all.
 

·
Registered
Joined
·
1,019 Posts
Discussion Starter #12
Boat cop if that solenoid for the 4 hi is out should I be able to use 4 low still if I shift into N first?

Again thanks
 

·
Registered
Joined
·
5,343 Posts
If the solenoid is out, it will not engage the front end at all in any gear. the transfer case will engage but not the front end. the only thing this solenoid does is take the place of the old manual locking hubs. there is a way to check it, unscrew it and have someone press the 4x4 button while you look at the plunger. if it does not push out, it is bad. I have seen this happen about 4 or 5 times. it is sort of like a choke on an outboard, it is just an electrical magnet.
 
1 - 13 of 13 Posts
Top