AZBZ Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
The light on my Motor Guide trolling motor went out. Does anyone know how hard that is to fix. Does the cap pop out or do I have to crack open the top part of the motor. Not sure how to get to the light bulb. Thanks in advance.
Bill
 

·
Registered
Joined
·
4,696 Posts
Sorry, I don't have an answer for you, but I do have the same problem. I'll look for replies also. Thanks for bringing it up!

Tater
 
G

·
Guest
Joined
·
0 Posts
MotorGuide

I don't know which model you have. I have the 767 Brute and will use that for reference. I believe they are the same. Pop the 3 screws off at the head. It's best if you have the motor in the vertical position. Before removing the top half , pay attention to the direction the arrow is pointing. Then proceed to take this piece off. Don't disturb the orientation of the lower trolling motor unit. Replace the bulb and reassemble. Piece of cake. Job takes all of 5 minutes (assuming you have light bulb).
 

·
Premium Member
Joined
·
34,643 Posts

·
Registered
Joined
·
4,696 Posts
Sorry, but there are no screws or other obvious access to the bulb on my model. I think that's why bpIII posted his original question. Maybe Motor guide can offer a suggestion as to how to fix this problem.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #8
Thank you

I needed a place to start. I think I do have the 767. I should ask the owner , Oh thats me. I will check it out. Is it a special bulb or can I get from anywhere or special order only from that place Del suggested.
Thanks
Bill
 

·
Premium Member
Joined
·
34,643 Posts
1 - 9 of 9 Posts
Top