Arizona Fishing Forums on AZBZ banner
1 - 9 of 9 Posts

·
Registered
Joined
·
509 Posts
Discussion Starter · #1 ·
Fried my T.motor on canyon this morning .Does any one know someone who can get me up and running before SAT.???im in a pinch to get it fixed fast,thanx for any info>>
 

·
Premium Member
Joined
·
34,643 Posts

·
Registered
Joined
·
509 Posts
Discussion Starter · #3 ·
when you step on the foot pedal its getting power to the lower unit ,but the prop wont turn unless you tap(bang)on the cone where the shaft and lower unit come together.Then when the prop turns (on full power)it moves real slow w/a grind to it!! ITS NOT TO PRETTY GOOD!! What do ya think???
 

·
Registered
Joined
·
7,248 Posts
TR21, have you removed the prop? maybe some line got up in there and is reaking havoc with your motor?
 

·
Registered
Joined
·
509 Posts
Discussion Starter · #5 ·
YEp its not a line in the prop thing,its definately coming from inside the lower unit.Im no pro but i think its an electrical thing or a motor thing.Plus when i took the cone off there was a lot of powder substance in the cone,im assuming from a little water getting inside the lower unit and causing electrolysis,but thanx!!
 

·
Registered
Joined
·
518 Posts
Howdy Tr21, I don't have a clue about your problem. But if your in need of something running by Sat. You are sure welcome to use the spare I have in the garage. It ain't much but it sounds like it'll outrun the one you got now :wink: It's a 34lb 12volt motor guide I live in the east Mesa area...Call me on my mobile if it helps.......602-818-1539 (Gary)
 

·
Premium Member
Joined
·
34,643 Posts

·
Registered
Joined
·
97 Posts
Ditto on te Minn Kota. Two years ago I bought a MG Brute 67. At yesterdays "friendly get together" the latch-down pin snaped in two. Now I have to tie the motor down until I can get a replacement. Seems like a goofy thing to break! :x
 
1 - 9 of 9 Posts
Top