Arizona Fishing Forums on AZBZ banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1,294 Posts
Discussion Starter · #1 ·
Saturday the pick up hose for my live well came disconected. All night I couldn't figure why the hell I couldn't get out of the hole, then finally after fishing one spot for about an hour I stepped back in to a pool. water was above my floor, the bilge went for about 35 minutes to get it all out! No wonder I couldn't get out of the hole, i thought something was wrong with my motor :IconrotflAnyone ever had this happen? I think i will be investing in an automatic float switch for my bilge...:blink:
 

·
Registered
Joined
·
5,825 Posts
I had the connector to one of my pumps break and it did the same thing but I had one manual and one auto bilge pump so I figured it out pretty fast. Get that switch put in.
 

·
Registered
Joined
·
5,302 Posts
Damn dude... That sucks. Only thing ive ever done simular to that was leavin the plug out and fillin the boat up
 

·
Registered
Joined
·
1,294 Posts
Discussion Starter · #5 ·
Ya, it was pretty gay. I don't know why they wouldn't put an auto in from the factory. Luckily I noticed before it covered up my batteries, then I would have been screwed.
 

·
Registered
Joined
·
6,870 Posts
It happened on my old boat james. Go buy some new tubing and once you have it on put a clamp on it and it should be good or if your existing hoses are still good just clamp it down.
 

·
Registered
Joined
·
674 Posts
Anyone know where you can get the switch/float? Mine got stuck on and I had to cut the power to it. I looked around and couldn't find it anywhere. It's a Mayfair.
 

·
Registered
Joined
·
6,622 Posts
I have seen the float at of all places K-mart and they make a neat pump now that has the float built into the bilge pump--bought that at Kmart also and installed it in the small boat, you can put it in auto mode or turn it on directly and has good GPH rating and does not take up anymore room than a standard bilge pump.
 
1 - 11 of 11 Posts
Top